Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Renaming eq_by to related_by #100795

Open
Hiten-Tandon opened this issue Aug 20, 2022 · 2 comments
Open

Renaming eq_by to related_by #100795

Hiten-Tandon opened this issue Aug 20, 2022 · 2 comments
Labels
T-libs-api Relevant to the library API team, which will review and decide on the PR/issue.

Comments

@Hiten-Tandon
Copy link

Hiten-Tandon commented Aug 20, 2022

Take a look at the following code [Rust Playground]

#![feature(iter_order_by)]

fn main() {
    let xs = [1, 2, 3, 4];
    let ys = [1, 5, 10, 16];

    assert!(xs.iter().eq_by(&ys, |&x, &y| x * x <= y));
}

eq_by name suggests that the function can only be used for checking if the two iterators are equal however, as you can see, the function can check for any relation, not just equality thus it should be renamed to related_by.

Instead another function named eq_by/eq_by_key should be created similar to this but, instead of taking a closure that takes two inputs of same type, it should take in one input, and return a generic data type which implements PartialOrd, then this data can be checked for equality.

Essentially, this eq_by/eq_by_key should be equivalent to a.iter().count() == b.iter().count() && a.iter().zip(b.iter()).all(|(ele_a, ele_b)| fn(ele_a) == fn(ele_b)) where a and b are two generic types that implement Iterator, and, fn is the function for generating argument, which is checked for equality instead.

Edit : Changed just eq_by to eq_by/eq_by_key and added a more specific description of eq_by/eq_by_key method as suggested by @timvermeulen.

@Hiten-Tandon Hiten-Tandon added the A-docs Area: Documentation for any part of the project, including the compiler, standard library, and tools label Aug 20, 2022
@timvermeulen
Copy link
Contributor

Instead another function named eq_by should be created similar to this but, instead of taking a closure that takes two inputs of same type, it should take in one input, and return a generic data type which implements PartialOrd, then this data can be checked for equality.

FWIW, this variant is usually spelled *_by_key in the Rust standard library, Iterator just happens to not have eq_by_key.

For comparing two iterators, the Iterator trait has the eq/eq_by, cmp/cmp_by, and partial_cmp/partial_cmp_by method pairs, as well as ne/lt/le/gt/ge methods with no *_by or *_by_key counterparts. IMO those last five don't add much value to Iterator and perhaps shouldn't have existed in the first place. For eq, cmp, and partial_cmp, though, it seems reasonable to me to add *_by_key versions of those.

Essentially, this eq_by should be equivalent to a.iter().zip(b.iter()).all(|(ele_a, ele_b)| fn(ele_a) == fn(ele_b)) where a and b are two generic types that implement Iterator, and, fn is the function for generating argument which is checked for equality instead.

Keep in mind that this may return true for two iterators with different lengths, so it doesn't behave exactly the same as the eq method.

@Hiten-Tandon
Copy link
Author

Keep in mind that this may return true for two iterators with different lengths, so it doesn't behave exactly the same as the eq method.

I have that in mind, that's why I said equivalent, instead of equal, however, I should've been more specific so, I'll just fix it right now.

For comparing two iterators, the Iterator trait has the eq/eq_by, cmp/cmp_by, and partial_cmp/partial_cmp_by method pairs, as well as ne/lt/le/gt/ge methods with no *_by or *_by_key counterparts. IMO those last five don't add much value to Iterator and perhaps shouldn't have existed in the first place. For eq, cmp, and partial_cmp, though, it seems reasonable to me to add *_by_key versions of those.

Well, in that case, eq_by_key is also fine, because it does convey similar meaning, just eq_by by itself, checking for relations, seems a bit misleading, though it's not catastrophically misleading, because one look at docs and you'd know what it's doing but, still, I do think that this method should be renamed to related_by, instead of eq_by

@GuillaumeGomez GuillaumeGomez added T-libs-api Relevant to the library API team, which will review and decide on the PR/issue. and removed A-docs Area: Documentation for any part of the project, including the compiler, standard library, and tools labels Sep 25, 2022
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
T-libs-api Relevant to the library API team, which will review and decide on the PR/issue.
Projects
None yet
Development

No branches or pull requests

3 participants