-
-
Notifications
You must be signed in to change notification settings - Fork 1.5k
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
[java] New expression and type grammar #1759
Conversation
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I still have to look into the grammar itself in more detail, but this is looking really good so far
pmd-java/src/main/java/net/sourceforge/pmd/lang/java/ast/ASTClassOrInterfaceType.java
Outdated
Show resolved
Hide resolved
pmd-java/src/main/java/net/sourceforge/pmd/lang/java/ast/ASTPrimitiveType.java
Outdated
Show resolved
Hide resolved
pmd-java/src/main/java/net/sourceforge/pmd/lang/java/ast/AbstractJavaNode.java
Outdated
Show resolved
Hide resolved
pmd-java/src/main/java/net/sourceforge/pmd/lang/java/ast/AssignmentOp.java
Show resolved
Hide resolved
pmd-java/src/main/java/net/sourceforge/pmd/lang/java/ast/AstImplUtil.java
Show resolved
Hide resolved
pmd-java/src/main/java/net/sourceforge/pmd/lang/java/ast/AstImplUtil.java
Outdated
Show resolved
Hide resolved
.../src/main/java/net/sourceforge/pmd/lang/java/rule/errorprone/AvoidDuplicateLiteralsRule.java
Outdated
Show resolved
Hide resolved
...rc/main/java/net/sourceforge/pmd/lang/java/rule/performance/AppendCharacterWithCharRule.java
Outdated
Show resolved
Hide resolved
I'd love to see test cases for the resolved issues, as some of the new added methods for completeness. |
pmd-java/src/main/java/net/sourceforge/pmd/lang/java/ast/AbstractJavaNode.java
Outdated
Show resolved
Hide resolved
pmd-core/src/main/java/net/sourceforge/pmd/lang/ast/AbstractNode.java
Outdated
Show resolved
Hide resolved
pmd-apex/src/main/java/net/sourceforge/pmd/lang/apex/ast/AbstractApexNodeBase.java
Outdated
Show resolved
Hide resolved
pmd-java/src/main/java/net/sourceforge/pmd/lang/java/ast/ASTAdditiveExpression.java
Show resolved
Hide resolved
So far I have separated these out (for 7.0.x):
The rebased version of this PR is in my branch pr-1759-rebased2. Unfortunately not much smaller yet. all are generic (aka not java related) - although one or two changes need some adjustments as well to fix compile errors or tests. Other things, that are generic, so should be separated and go into
Then there are the actual grammar changes, which should go into the
|
Re: checker framework I think, this is useful and we should use it in general as one of api design goals. Let me know if you agree/disagree. For this PR, I tend to keep the changes related to it in - although it modifies pmd-core/pom.xml ... But I think, adding the checker dependency in pmd-core is the correct way. Update: Actually, I moved adding the dependency to pmd-core out, but left everything else in. |
From PR #1824 * This PR is for PMD 7 * It's extracted from #1759 Changes: * adds the new `assertTextRangeIsOk`, that is executed on every node in * the kotlin-based tests * this ensures, that the position of the nodes in the AST is the same as * they appear in the source code * For the new switch labeled rules, we have the following grammar ``` void SwitchStatement(): {} { "switch" "(" Expression() ")" SwitchBlock() } void SwitchBlock() #void : {} { "{" ( SwitchLabel() ( "->" SwitchLabeledRulePart() (SwitchLabeledRule())* | ":" (LOOKAHEAD(2) SwitchLabel() ":")* (BlockStatement())* (SwitchLabeledStatementGroup())* ) )? "}" } void SwitchLabeledRulePart() #void: {checkForSwitchRules();} { ( ( Expression() ";" ) #SwitchLabeledExpression(2) | ( Block() ) #SwitchLabeledBlock(2) | ( ThrowStatement() ) #SwitchLabeledThrowStatement(2) ) } ``` `#SwitchLabeledBlock(2)` takes the last two nodes (SwitchLabel + Block) and adds them as SwitchLabeledBlock to SwitchStatement. JavaCC sets the first token of SwitchLabeledBlock to be the Block node, but it should be the SwitchLabel node. This is fixed in the `jjtClose` methods in the three related SwitchLabeled* nodes. On the expression grammar PR, there is a better solution (you can mark the nodes via the interface `LeftRecursiveNode`). * So, this actually fixes a bug, that is present in PMD 6.
From PR #1823 * This PR is for PMD 7. * It's extracted from #1759 Changes: * The children array in AbstractNode is now initialized with an empty * array. * This means, it is now never null, thus the null checks can be removed. * The only change to the children array is, when adding a new child * (`jjtAddChild`), or removing a child (`removeChildAtIndex`). Future: * the children array is protected. This means, sub classes could assign * null to it... do we really need field available in subclasses? I'd * assume, the already available methods are enough. -> this is something * for defining a general AST API (which methods should be package * private only, as they are only used by the parser, which methods * define the API, when do we implement iterator, etc..)
From PR #1827 * This PR is for PMD 7 * It's extracted from #1759 This only adds the dependency (compile time), and does not make use of it yet. I've added a section in the wiki: https://github.com/pmd/pmd/wiki/PMD-7.0.0-API We'll need to flesh out the details over time and verify our APIs, that we have properly annotated them (if we all agree, that we use `@Nullable`).
@adangel I investigated the failing tests and fixed the following problems:
I also ignored some tests:
With those changes, the remaining failing tests are either tests of type resolution, or of the symbol table. I think we should ignore them too while we're not done with the AST. And I think we should proceed with #1566 instead of fixing the current symbol table. |
No numeric promotion is performed when comparing numeric values. Some implicit assertions are added to check an invariant about literals.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
So, I finally got through the changes. I think we should merge this PR and then work step by step on the open TODOs.
Here are some general notes/TODOs:
-
I've added the TODOs I've found in the code here: https://github.com/pmd/pmd/wiki/PMD-7.0.0-Java#todo
-
Are the following issues now fixed or what is missing? Maybe we can go through each one by one?
- #1661 About operator nodes
- #1367 Parsing error on annotated subclass
- #1150 ClassOrInterfaceType AST improvements
- #1019 Breaking Java Grammar changes for PMD 7.0.0
- #997 Java8 parsing corner case with annotated array types
- #910 AST inconsistency between primitive and reference type arrays
- #497 RFC: new layer of abstraction atop PrimaryExpressions
-
grammar: java.jjt
- TODO for later: cleanup grammar to remove checks for old java version (like check for bad diamond usage...). When do we do this? I think, it should be also done on the java-grammar branch?
- We sometimes have *List nodes, but sometimes they are #void. E.g. LambdaParameterList is not void, but AnnotationList is...
-
Documentation
- Example usage of AssignmentOp (AssignmentExpressions), with the removal of ASTAssignmentOperator
- Annotation() is now #void
- ASTParenthesizedExpression: provide example to illustrate how the AST is improved now
Deprecations due on PMD 6.x
-
constructors or methods, that are package private now. We need to mark them on the master branch first.
-
maybe we should simply go through all AST nodes on master and mark them accordingly for once
-
Classes
- ASTAdditiveExpression (constructor, getOperator())
- ASTArgumentList (constructor)
- ASTArrayInitializer (constructor)
- ASTBooleanLiteral (constructor, setTrue())
- ASTCastExpression (constructor, setIntersectionTypes/hasIntersectionType())
- ASTCatchStatement (constructor)
- ASTClassOrInterfaceType (constructor, isArray() and getArrayDepth())
- ASTConditionalAndExpression (constructor)
- ASTConditionalExpression (constructor)
- ASTEnumConstant (constructor, getQualifiedName())
- ASTEqualityExpression (constructor, getOperator())
- ASTExplicitConstructorInvocation (constructor, setIsThis(), setIsSuper())
- ASTLambdaExpression (constructor)
- ASTMarkerAnnotation (constructor, getAnnotationName())
- ASTMemberValueArrayInitializer (constructor)
- ASTMemberValuePair (constructor)
- ASTMethodDeclarator (constructor)
- ASTMethodReference (constructor)
- ASTMultiplicativeExpression (constructor, getOperator())
- ASTName (constructor)
- ASTNormalAnnotation (constructor, getAnnotationName())
- ASTNullLiteral (constructor)
- ASTPostfixExpression (constructor)
- ASTPrimitiveType (constructor)
- ASTRelationalExpression (constructor)
- ASTShiftExpression (constructor, getOperator())
- ASTSingleMemberAnnotation (constructor, getAnnotationName())
- ASTSwitchStatement (constructor)
- ASTTypeBound (getBoundTypeNodes())
- ASTTypeParameter (constructor)
- ASTUnaryExpression (constructor)
Nodes/classes that are deprecated on PMD 7, but not on PMD 6
-
should we remove them directly in PMD 7 and deprecate in 6?
-
we need to deprecate them at least in PMD 6Since we have no replacement for them on 6.0.x, we won't deprecate them (it would only be noise to users). Instead we should keepnext_major_development.md
up-to-date with the planned deprecations, and maybe link to it in the minor release notes to keep users informed.- ASTAllocationExpression
- ASTArguments
- ASTArrayDimsAndInits
- ASTAssignmentOperator
- ASTMemberSelector
- ASTMemberValuePairs
- ASTTypeArgument
- ASTUnaryExpression (method getOperator())
- ASTUnaryExpressionNotPlusMinus
- ASTVariableInitializer
- ASTWildcardBounds
- JavaParserVisitorReducedAdapter
Nodes that are moved from class to interface
- How do we mark these? Should we mark these nodes in PMD 6 as deprecated as well (is this useful at all?)?
- ASTAnnotation
- ASTLiteral
- ASTMemberValue
- ASTPrimaryExpression
- ASTReferenceType
- ASTType
- ASTVariableInitializer (note: this is also deprecated in PMD 7...) Yes this is kept for compatibility with rules but is not necessary
- Double File License: Some AST nodes have the license header twice. Not sure, if I introduced this during rebase... oowekyala: This is because when I copy paste node files to create new ones, IntelliJ ignores the copyright comment if it starts with a double star like a javadoc one, and inserts a new comment.
- Commented out code and removed test cases - we need to revisit later and not to forget
- NameFinder
- ClassTypeResolver
- ASTAssignmentOperatorTest
- ASTFieldDeclarationTest.testGetVariableName()
- ASTLiteralTest
- ASTPrimarySuffixTest
pmd-java/src/main/java/net/sourceforge/pmd/lang/java/ast/TokenOps.java
Outdated
Show resolved
Hide resolved
* | ||
* @throws NoSuchElementException If there's less than n tokens to the left of the anchor. | ||
*/ | ||
// test only |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Do you mean, this method is public only for tests? Do we need an annotation @TestOnly
?
pmd-java/src/main/java/net/sourceforge/pmd/lang/java/rule/AbstractJavaRule.java
Show resolved
Hide resolved
pmd-java/src/main/java/net/sourceforge/pmd/lang/java/typeresolution/ClassTypeResolver.java
Outdated
Show resolved
Hide resolved
They conflict with pmd#1759
(This is testable with the jar in the wiki)
Main changes
There are many things still to do to have a consistent AST, eg the new ArrayTypeDims should be used in the other places it's meant for, Dimensionable should be removed, etc. This is already big enough (keep in mind, about half of the line changes are tests).
All the changes to the AST structure are already described on this wiki page in the category "Done".
There's one change that was not in the preview version you've already seen: the parameters of lambda expressions are now their own node, which removes inconsistencies between the case when there's a single VariableDeclaratorId and the case where there's a full FormalParameter.
Temporary measures
PrimaryExpression
JavaCC doesn't support left-recursion, so the left recursive nodes are built by manipulating the jjtree stack.
You can see in alljavacc.xml that the method
extendLeft
is inserted inJJTreeJavaParserState.java
. This bumps the arity of the current node (the one being built, ie is not on the stack) by one, which means that if the node ends up being closed, the node that was pushed immediately before the current one is added as a child of the current node.The productions PrimaryPrefix and PrimarySuffix are kept but made
#void
..foo()
or::new
. TheextendLeft
method is called systematically by all of those productions to enclose the previous node on the stack, which necessarily exists because we've already parsed a PrimaryPrefix (or another suffix).Disambiguation
The parser needs to parse AmbiguousNames to keep lookaheads to a minimum. The disambiguation that uses only syntactic context is implemented at various points in the parser and the initialization code of the nodes
Since this version already needs to reclassify some ambiguous names, the machinery to actually replace a name with an unambiguous version is already in place. A later PR can add a naive disambiguation pass that uses the current symbol table in order to remove most of the ambiguous names
Operator nodes (#1661)
That's implemented using basically the same template for all the relevant nodes. See
AbstractLrBinaryExpr
and eg the productionShiftExpression
Optional vs
@Nullable
One thing I decided which may be controversial is not to use
java.util.Optional
in the AST API. Instead I went with JSR 305's@Nullable
and@Nonnull
annotations, for several reasons:isEmpty
method,ifPresentOrElse
, oror
(added in Java 11, 9 and 9 respectively), there's still noifEmpty
. Many times you just want to check whether a node is present, in which case dealing with Optional instead of doing a simple null check is obnoxious. When you do want to use Optional features likemap
or stuff thenOptional.ofNullable
is easy to add.QualifiableExpr { @Nullable getLhs(); }
and implement it inASTArrayAccess
with a@Nonnull
, instead of having to return a never-empty Optional.@NoAttribute
This is used to remove the XPath attributes of ASTAmbiguousName to the minimum. It has many irrelevant attributes because it implements ASTExpression and ASTType (maybe that should be changed though). We can eg also use it to remove the
@Image
attribute from the new nodes to avoid people using them. It's pretty simple but not tested yet.Other stuff
children
table is never null (just use an empty array). That makes it easier to work with and also ensures that when trying to fetch a child that doesn't exist, only ArrayIndexOutOfBoundsException is thrown, and never NullPointerExceptionvisit(ASTExpression)
effectively visits all expressions.visit(ASTExpression)
and notvisit(ASTMethodLikeNode)
. I think it should be removed entirely, it makes LambdaExpression implement AccessNode (!). This can go with a simplification of the metrics framework. There's no reason that metrics be constrained to be computed on methods, most of them can actually be computed on any block of code...