-
-
Notifications
You must be signed in to change notification settings - Fork 1.5k
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
[java] New Rule: Use Explicit Types #2847
Comments
Sounds like it could be useful in some codebases. I think it's not useful to have separate properties for local variables, Maybe an interesting property would be to allow the use of Also, name suggestion: UseExplicitTypes |
I do not know how useful this is. I personally would like to never see a Can a var be used in a lambda parameter (e.g. I like the name |
When using https://wiki.c2.com/?MeaningfulName While I don't have any suggestions as yet, the above links might be useful. |
Thanks for the links! Those are interesting reads. So, if you use |
Precisely so! You could create a rule for meaningful variable names for |
As a human, coming up with meaningful names is sometimes hard. I have to spend up to a few minutes. The links help give some ideas. I figure we would need some AI to be able to replace a human. We could use a generative adversarial network (GAN) fed with good variable names and the data types. IDEs would use the generator for code auto-completion (i.e. the programmer types a data type and the IDE prompts with variable names). PMD would use the discriminator to detect variable names that do not go with certain data types. For example, a variable name such as However, good variable names is not the point of this ticket and should be put in a separate a ticket. (See 2868). This ticket simply bans the use of |
As far as I can see, |
The only other reason to use |
LooseCoupling only works on fields, method parameters and method returns types. |
When in doubt, add a property and let the development team decide. |
Hmm....I seem to have missed that. I've been coding against interfaces and ADTs in my test cases. Now, I'm wondering why I went to all that trouble? Extend the rule, perhaps, retaining the defaults? |
I revisited the article:
|
Adding my +1 here. Personally, I think adding Case no. 1 (really bad) final var user = getUser(userId); Try figuring out the type in a GitHub PR for code like that. Especially if you have both Case no. 2 (more acceptable) final var message = "The message"; This is because for some variable declarations the type is to the left of the variable name (for those not using Personally, I would be very satisfied with having a rule that prohibits |
One option I would like to see: allow // fail - this line does not tell you what type `x` is
var x = performSomeOperation();
// pass - you can see that `y` is a `Foo`
var y = new Foo(); |
This rule would not be so much of an issue if you had a tool that infers the correct type for |
The following code is much easier to read because all the variables are declared at the top of the method. Methods are encouraged to be short due to other PMD rules and testability so the variable declarations are always visible on the screen.
|
I've rarely come across this style of coding for Java. Can you point to some code-bases (on GitHub) that follow your suggested methodology? |
Section 6.3 on https://www.oracle.com/java/technologies/javase/codeconventions-declarations.html is close. The code still initializes and declares on the same line. This doesn't make sense. You don't want to initialize all the variables with dummy values just to have the variables at the top of the method. Then we have the Google Java Style Guide section 4.8.2.2 that says to declare variables when needed. https://google.github.io/styleguide/javaguide.html#s4.8-specific-constructs Instead of guides and code examples, we need to find a study that shows which style leads to faster code reading and comprehension. |
See my comment above. I used to think the same. But now I think that I would be very happy for a rule that forbids In Kotlin, things are a bit better - the type is always to the right of the variable name, but in Java, as far as I'm concerned |
There's one disadvantage of doing things this way: the "extract method" refactoring in IntelliJ will not work very well. That refactoring works best if the variables are declared as close as possible to the code that uses them. |
For others like me, looking to forbid the usage of <module name="TreeWalker">
...
<!--
Disallow usage of variable type inference using the `var` keyword.
Using `var` makes the code harder to read in all contexts except IntelliJ,
because the brain has to work extra to try to understand what is the type,
and in some cases it's impossible to know it - e.g. `var house = getHouse()`.
This is particularly nasty when doing PR reviews in GitHub.
There are a few where the type is directly visible:
* in primitive assignments: `var done = false`, `var maxAge = 39'
* in constructor assignments: `var person = new Person(...)`
While these cases are much better, they still pose a problem: our brains
are used in Java code to see the type to the left of the variable name.
If we are mixing `var` and non-`var` declarations, now the type will
sometimes be shown to the left of the variable name (non-`var`), and
sometimes to the right of the variable name (when using `var`).
This adds a bit of extra work for the brain, so `var` is also not
recommended in these cases. The extra brain power can be better used
to understand the intent of the code, rather than to parse Java syntax.
-->
<module name="MatchXpath">
<property name="query" value="//VARIABLE_DEF/TYPE/IDENT[@text='var']"/>
<message key="matchxpath.match" value="The `var` keyword should be avoided to keep the code easier to understand"/>
</module>
</module> I strongly suspect this can also be done with PMD's |
Absolutely! You can always use the out of the box rule designer for easily creating these… but it would go something along the lines…
The attribute You can filter out scenarios for where this is used (try-with-resources, for loop, etc.) by looking at ancestors. |
Proposed Rule Name: UseExplicitTypes
Proposed Category: One of [Best Practices | Error Prone]
Description:
Java 10 introduced the
var
keyword. This reduces the amount of typing but decreases the reading comprehension of the code. Please create a rule that flags the use of the var keyword.Code Sample:
The line with
var index
should be flagged as a problem.Here is the "correct" code.
Possible Properties:
disallow
.disallow
.disallow
.disallow
. Iftrue
, thenvar
can replace a primitive type as long as one of the above properties allows the location.Are there any other places where
var
can be used? If so, add those as properties.The text was updated successfully, but these errors were encountered: