Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

refactor: Rename 'tasks_query_*' properties to 'TQ_*' #3316

Merged
merged 5 commits into from
Feb 8, 2025

Conversation

claremacrae
Copy link
Collaborator

Types of changes

I hummed and hahed on the prefix for this, eventually settling on refactor because it is changing a facility that is not yet released.

Changes visible to users:

  • Documentation (prefix: docs - improvements to any documentation content for users)
  • Sample vault (prefix: vault - improvements to the Tasks-Demo sample vault)

Internal changes:

  • Refactor (prefix: refactor - non-breaking change which only improves the design or structure of existing code, and making no changes to its external behaviour)
  • Tests (prefix: test - additions and improvements to unit tests and the smoke tests)
  • Infrastructure (prefix: chore - examples include GitHub Actions, issue templates)

Description

Shorten the Query File Defaults property names:

  • from:
    • tasks_query_*
  • to:
    • TQ_*

Motivation and Context

Although I prefer the longer, more descriptive names, I found them to be just too wide when looking at the File Properties view on a fairly large iPhone screen.

How has this been tested?

  • Automated tests
  • Exploratory testing

Screenshots (if appropriate)

image

Checklist

Terms

tasks_query_show_scheduled_date and similar turned
out to be just too long on mobile phones, even after using
CSS to widen the property names.
tasks_query_show_scheduled_date and similar turned
out to be just too long on mobile phones, even after using
CSS to widen the property names.
tasks_query_show_scheduled_date and similar turned
out to be just too long on mobile phones, even after using
CSS to widen the property names.
@claremacrae claremacrae added the scope: frontmatter Anything to do with YAML frontmatter, also known as Obsidian properties label Feb 8, 2025
Copy link

sonarqubecloud bot commented Feb 8, 2025

@claremacrae claremacrae merged commit faf6652 into main Feb 8, 2025
4 checks passed
@claremacrae claremacrae deleted the shorten-property-names branch February 8, 2025 15:37
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
scope: frontmatter Anything to do with YAML frontmatter, also known as Obsidian properties
Projects
None yet
Development

Successfully merging this pull request may close these issues.

1 participant