-
Notifications
You must be signed in to change notification settings - Fork 40.3k
New issue
Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.
By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.
Already on GitHub? Sign in to your account
Rename KubeConfigFile to Kubeconfig in ClientConnectionConfiguration #67149
Rename KubeConfigFile to Kubeconfig in ClientConnectionConfiguration #67149
Conversation
0ff20c9
to
2ff9bd6
Compare
/lgtm |
// kubeConfigFile is the path to a kubeconfig file. | ||
KubeConfigFile string `json:"kubeconfig"` | ||
// kubeconfig is the path to a KubeConfig file. | ||
Kubeconfig string `json:"kubeconfig"` |
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
I guess we are not worried about backward compatibility issues here, right?
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
actually, the json name is the same. So, NVM.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
No, we aren't. However, the JSON is backwards-compatible with this change.
This is all alpha, and we're trying to get to a state where we can move types out, do a full field-by-field review on everything, change stuff if needed and then graduate individual components' types to v1beta1
and higher.
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
Sounds good. I already approved. Thanks!
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
/lgtm
There was a problem hiding this comment.
Choose a reason for hiding this comment
The reason will be displayed to describe this comment to others. Learn more.
/lgtm
/approve
[APPROVALNOTIFIER] This PR is APPROVED This pull-request has been approved by: bsalamat, liggitt, luxas, timothysc The full list of commands accepted by this bot can be found here. The pull request process is described here
Needs approval from an approver in each of these files:
Approvers can indicate their approval by writing |
Automatic merge from submit-queue (batch tested with PRs 67061, 66589, 67121, 67149). If you want to cherry-pick this change to another branch, please follow the instructions here. |
Automatic merge from submit-queue (batch tested with PRs 67071, 66906, 66722, 67276, 67039). If you want to cherry-pick this change to another branch, please follow the instructions <a href="https://github.com/kubernetes/community/blob/master/contributors/devel/cherry-picks.md">here</a>. Remove references to the structs that have moved to their own packages **What this PR does / why we need it**: Follows-up #66058 and #66059 to remove the structs that now aren't needed in `pkg/apis/componentconfig` **Which issue(s) this PR fixes** *(optional, in `fixes #<issue number>(, fixes #<issue_number>, ...)` format, will close the issue(s) when PR gets merged)*: xref kubernetes/community#2354 **Special notes for your reviewer**: This PR depends on: - [x] #67090 - [x] #67149 - [x] #67159 - [x] #67207 **Only review commit 'Remove references to the structs that have moved to their own packages' please** **Release note**: ```release-note NONE ``` /kind cleanup /assign @sttts @thockin @jbeda @liggitt
Automatic merge from submit-queue. If you want to cherry-pick this change to another branch, please follow the instructions here: https://github.com/kubernetes/community/blob/master/contributors/devel/cherry-picks.md. Refactor the kube-controller-manager ComponentConfig structs **What this PR does / why we need it**: This PR cleans up the kube-controller-manager structs in the componentconfig package and fixes various structural issues in the current code, in order to make it possible to later move the code out to external API groups (as a starting point `GenericControllerManagerConfiguration` to `k8s.io/controller-manager`). **Which issue(s) this PR fixes** *(optional, in `fixes #<issue number>(, fixes #<issue_number>, ...)` format, will close the issue(s) when PR gets merged)*: ref: kubernetes/community#2354 This PR depends on: - [x] #67149 - [x] #67090 - [x] #67159 - [x] #67207 - [x] #66722 **Special notes for your reviewer**: Please only review the following commits: - **Refactor the k-c-m ComponentConfig structs to they can be moved out** - **Fixup cmd/kube-controller-manager code after struct changes.** **Release note**: ```release-note NONE ``` /assign @sttts @stewart-yu @liggitt @thockin
What this PR does / why we need it:
As discussed with @liggitt we should make the field name and JSON tag consistent, and we concluded
Kubeconfig
andkubeconfig
is the most consistent naming we have (e.g. wrt--kubeconfig
), so we're going with that naming for theClientConnectionConfiguration
struct. Also, this preserves backwards-compat wrt existing serialized configuration. This fixes the API violation.Which issue(s) this PR fixes (optional, in
fixes #<issue number>(, fixes #<issue_number>, ...)
format, will close the issue(s) when PR gets merged):ref: kubernetes/community#2354
Special notes for your reviewer:
Release note:
/assign @liggitt @sttts