Skip to content

Add a wrapper for accessing the URL launcher service. - #4688

Merged
chinmaygarde merged 1 commit into
flutter:masterfrom
chinmaygarde:master
Jun 24, 2016
Merged

chinmaygarde merged 1 commit into
flutter:masterfrom
chinmaygarde:master

Conversation

@chinmaygarde

Copy link
Copy Markdown
Contributor

Copy link
Copy Markdown
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

There's a bit more ceremony required here. See the other wrappers for the pattern.

@chinmaygarde

Copy link
Copy Markdown
Contributor Author

I see, I didn't pull in the changes made recently and was basing this off of an older pattern a8f6f44#diff-7d620ba5e4aa11648c48a973a928da2fR33

Copy link
Copy Markdown
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

I think we're going to want to use the term URL instead of URI. Ask @Hixie about that.

@chinmaygarde

Copy link
Copy Markdown
Contributor Author

Android will parse the string as conforming to RFC 2396 while iOS expects the string to conform to RFC 1738. I believe 2396 updates 1738 and RFC 3986 updates or obsoletes both. So depending on the platform, there will be subtle changes in the conformance requirements of the string. That is why the mojom specifies that the platform will parse this instead of us. I associate URL with 1738 and URI with the others.

@Hixie

Hixie commented Jun 22, 2016 •

Copy link
Copy Markdown
Contributor

The URL standard obsoletes RFC 3986, RFC 2396, and RFC 1738.

@chinmaygarde chinmaygarde changed the title Add a wrapper for accessing the URI launcher service. Add a wrapper for accessing the URL launcher service. Jun 24, 2016
@chinmaygarde

Copy link
Copy Markdown
Contributor Author

Done. Another look?

Copy link
Copy Markdown
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

a/URLLauncher/UrlLauncher/

@abarth

abarth commented Jun 24, 2016

Copy link
Copy Markdown
Contributor

LGTM

@chinmaygarde

Copy link
Copy Markdown
Contributor Author

Done. Rebased.

@chinmaygarde
chinmaygarde merged commit 490622b into flutter:master Jun 24, 2016
@github-actions github-actions Bot locked as resolved and limited conversation to collaborators Aug 15, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

4 participants