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Copyright
No part of this document may be reproduced or transmitted in any form or by 
any means, electronic or mechanical, including photocopying and recording, 
for any purpose without the express written consent of Boris FX.

Copyright © Boris FX 2025. All Rights Reserved

February 18, 2025

About Us
Founded in 1995, Boris FX is a leading developer of VFX, compositing, titling, 
video editing, and workflow tools for broadcast, post-production, and film 
professionals. Boris FX products have grown to serve over a million artists 
worldwide. The company’s success lies in its ability to tightly integrate and 
leverage technologies through strong partnerships with Adobe, Apple, Avid, 
Blackmagic Design, Autodesk, FilmLight, Grass Valley, Magix, SGO, and other 
leading developers of video editing software. In 2014, Boris FX acquired 
Imagineer Systems, the Academy Award-winning developer of Mocha planar 
tracking software. In 2016, Boris FX acquired GenArts, the developer of 
Sapphire, the gold standard plug-in package for high-end visual effects. In 
2019, Boris FX acquired the Academy Award-winning Silhouette for advanced 
feature film rotoscoping, painting, and effects.



Silhouette 2024 What’s New    

• 
• 
• 
•
•
•

Silhouette 2024.5.6 - 2/18/25  3 
• 
• 
• 
•
•
•

 SILHOUETTE 2024.5.6 - 2/18/25

Bug Fixes
Numeric Field Adjustment Issues

Alt-Mouse Wheel Adjustments
Hovering over a numeric field and using Alt+mouse, Alt+Shift or 
Alt+Ctrl/Cmd did not work properly.

Arrow Key Adjustments
Hovering over a numeric field and using the Up/Down Arrows, 
Shift+Up/Down Arrows or Ctrl/Cmd+Up/Down Arrows did not work properly.

Plug-in Paint > Alpha > Brush Mask / Painted Alpha Output 
Was Incorrect

The OFX Paint > Alpha > Brush Mask and Painted Alpha output was incorrect. 
The input alpha was not getting cleared and there was opaque alpha in 
unpainted areas.

Scripting - presets.py broken
presets.py had a bug with the dictionary iteration.

Changes
Mask ML / EZ Mask Alpha Overlay Behavior

Previously, Mask ML and EZ Mask automatically turned the alpha overlay on 
and then turned it off when selecting another node. Now, the alpha overlay 
does not turn off when going to another node to be consistent with the behavior 
of other nodes.

Paint - Alpha Only Behavior
Opaque is now disabled by default when painting only in the alpha channel. 
This is more intuitive when painting luminance values in the alpha.
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 SILHOUETTE 2024.5.5 - 2/11/25

Bug Fixes
Adaptive Update Mode Zoomed In To Left Corner

When using a roto node with Adaptive update mode, editing spline points 
caused the image to zoom in to the top left corner and the Magnifier window 
disappeared.

Alt+Enter In Script Editor Ran Twice
Pressing Alt+Enter in the script editor (to run the script) executed twice.

Obey Matte Parameters Missing
Obey Matte parameters could disappear in some cases.

Paint - Color & Detail Modes Painted Black Alpha
In Paint, when Alpha and Opaque were enabled, Color and Detail modes 
painted black into the alpha channel instead of white like in Normal mode.

Pixel Color Status Bar Didn’t Work With GPU Nodes
The pixel color status bar didn’t work with GPU nodes.

Power Matte Render Skipped Some Files
When rendering Power Matte to an alpha only format, some frames were 
missing from the rendered files.

QT SVG
Silhouette now supports the QtSvg module which provides classes for 
rendering and displaying Scalable Vector Graphics (SVG) images. To 
accomplish this, Qt+PySide2 was upgraded to 5.15.15. On Windows and Mac, 
Python was also updated to 3.10.

Stereo Align Crash (Windows)
On Windows only, clicking on the Stereo Align icon crashed Silhouette.
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 SILHOUETTE 2024.5.4 - 12/20/24

Features
Matte Assist Propagation Mode

When using a reference frame not at the start, Propagation Mode produces a 
more accurate result since it propagates both forward and backward and not 
just from frame 1 as before.

Propagation Mode
Controls at what frame matte propagation starts which can be both forward and 
backward from a frame.

Auto
Matte propagation starts with the first keyframe.

Custom
Matte propagation starts with the frame defined in Start Frame.

Start Frame
Sets the matte propagation start frame when in Custom mode and defaults to 
frame 1.

Bug Fixes
EXR - Select Metadata Attributes Removed

Silhouette was to stripping certain attributes from the EXR metadata. For 
instance, "chromaticities" and "timeCode" were removed on a roundtrip through 
Silhouette.

Mask ML
Did Not Use The GPU On Intel Mac
Mask ML did not use the GPU on an Intel Mac and was very slow.

Mask ML Result Offset
After playing back Matte Assist ML and then selecting Mask ML, the Mask ML 
result was offset until the cache was cleared.
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Matte Assist ML
Crashing When Connecting Mask ML Output To Matte Assist ML 
Data Port
Sliding Matte Assist ML underneath Mask ML connected the output of Mask ML 
to the data port of Matte Assist ML which caused a crash.

Crash When Connecting Matte Assist ML to Resize
Silhouette crashed when sliding Matte Assist ML to connect to a Resize node.

Render Failure With PNG/JPG Alpha Only 
Rendering a PNG/JPG alpha only output image sequence failed after 20-30 
frames.

OFX - HazyByFilmConvert Blacklisted
HazyByFilmConvert was added to the Silhouette OFX blacklist as it was 
causing a crash on start.

Resize Created Padded Result
An image larger than the Session with Resize to scale it down to size created 
a padded result with black borders.

Roto
Artifacts With Open Shapes Set To Cap Style > Round
There were visible horizontal or vertical artifacts on open shapes when using a 
round cap style and when the cap got so small there was nothing for it to 
generate.

Artifacts With Open Shapes That Had Color > Outline Enabled
Open shapes rendered into RGB always went through the same outliner 
process that closed shapes did, which was not correct and it created horizontal 
or vertical artifacts. It actually made them render twice as thick because it was 
outlining the stroke. Now, open shapes rendered into RGB will use the actual 
open shape thickness instead of the Roto outline thickness.
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Stability With A Transform Node Caused A Crash
When there was a Transform node before Stability, clicking Generate caused a 
crash.

Limitation
Stability v3.5 Models Don’t Support Images Larger Than 
10mb

If the resulting image produced by Stability is larger than 10mb, an error occurs 
stating that payloads cannot be larger than 10mb. To avoid the error, reduce the 
image size, for instance to 1920x1080, prior to generation.
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 SILHOUETTE 2024.5.3 - 12/3/24

Bug Fixes
Cache Node Did Not Create Disk Cache Folder When Using 
The Fusion Tab In Resolve

When using the Fusion tab in Resolve, adding a Cache node did not create a 
disk cache folder and save the files when playing back. However, this worked 
as expected when applying Silhouette through the Color tab.

Copyright Notice Wrong In Finder Properties (Mac)
The copyright notice in the Mac Finder properties for Silhouette did not display 
properly.

Crash When Loading JPEG Via QImage (Linux)
When attempting to load a jpeg image when scripting, Silhouette crashed on 
Linux.

Crash When Typing A Number Into Current Frame Field
Double-clicking a clip in the Sources windows and then typing either a number 
into the current frame field or clicking the Up or Down arrows caused a crash.

Flame 2025.2 Background Reactor Render (Mac)
In Flame 2025.2 on macOS, setups with Silhouette were not rendering when 
using the Background Reactor.

Mask ML Did Not Function On Intel Mac
Mask ML did not produce alpha for the object, but instead selected the entire 
image. However, when on an Intel CPU, it falls back to the general-purpose 
CPU cores which are not efficient for such tasks and is very slow.

Matte Assist ML Failed On NVIDIA Virtual GPU (Linux)
On Linux, Matte Assist ML matte propagation failed with a CUDA error on a 
virtual GPU.
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Nuke 9+ Shapes Export Error
When the Nuke 9+ Shapes > Convert Opacity To Lifetime preference was 
enabled and there were opacity keyframes present in the selected shapes, 
exporting to disk produced an error in the Console.

Session Creation With A 25fps Clip Did Not Automatically 
Select A 25fps Session

Creating a session with a 25fps clip using Ctrl/Cmd-N selected a 23.976 fps 
session instead of a 25fps session.

Transform > Motion Blur > Shutter Phase Wasn’t Set To -90
The Transform > Motion Blur > Shutter Phase defaulted to 0 instead of -90.

Changes
Mask ML - Wipe Incoming Alpha

Mask ML now automatically wipes the incoming alpha to avoid the issue of 
sources with opaque alpha displaying a full screen overlay prior to object 
selection.
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 SILHOUETTE 2024.5.2 - 11/4/2024

Features
EZ Mask / Mask ML - Automatically Show Mask Overlay

When going into the EZ Mask and Mask ML nodes, the mask overlay now 
automatically appears when a mask is created. When exiting the EZ Mask and 
Mask ML nodes, the Viewer returns to RGB mode.

Stability Enhancements
Added Stability v3.5 models and negative prompts.

Switch Node
Switches between inputs. By default, four inputs are provided, but more can be 
added. Right-click on the Switch node and select Add Input. Right-click on an 
added input port to remove it. You can add as many inputs as you want, but the 
inputs will get smaller.

Bug Fixes
Adding A Font To The QT Font Database Caused A Crash

When a new font was added to the QT font database while Silhouette was 
running, it triggered font selection signals from the QT font drop-down menu. 
This would cause Silhouette to crash because it assumed there was an active 
node’s note being edited.

Crash When Selecting A Paint Node Created In A Different 
Session Size Bit Depth

Silhouette crashed if you copied a Paint node with strokes created in one bit 
depth, copy/pasted it into different bit depth and then selected it.

Magnifier Displayed Black
The Magnifier displayed black in the Roto based nodes.
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Mask ML > Rectangle Did Not Produce A Mask When 
Rectangle Was Outside Image

A rectangle outside the image boundary did not create a mask.

Planar/Mocha Trackers Didn't Accurately Track In Nested 
Layers

The Planar and Mocha trackers didn't accurately track within a nested layer.

Scroll Wheel Adjusted Parameters With Sliders Visible
Disabled scroll-wheel parameter adjustment when sliders are enabled because 
parameters could mistakenly be adjusted when scrolling filters with a lot of 
parameters.

Shape Transform Bounding Box Jittered When Stabilized
The shape transform bounding box jittered in a stabilized layer.
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 SILHOUETTE 2024.5.1 - 10/02/24

Features
ML Nodes With Animated DOD

Denoiser ML, Mask ML, Matte Assist ML and UpRes ML now work with an 
animated DOD.
Note: On Linux, animation of the DOD’s size is not supported.

Particle Illusion 2024.5.4
Particle Illusion has been updated from v2024.5.2 to v2024.5.4. For a complete 
list of features, fixed bugs and changes, see: Release Notes

Sapphire 2024.5.3
Sapphire has been updated from v2024.5 to v2024.5.3. For a complete list of 
features, fixed bugs and changes, see: Release Notes

Scripting - Import Dialog In Trees Window
Two new environment variables are supported for the Trees > Import Nodes 
feature:

• SFX_NODES_IMPORT_EXPORT_PATH - both import and export

• SFX_NODES_IMPORT_PATH - import only

Bug Fixes
Color Estimation Crash

The Color Estimation node caused a crash when certain nodes preceded it.

Color Precision In 8 Bit Sessions
The color precision was increased when working in 8 bit sessions.

GPU Display Always At 0%
The GPU percentage always displayed 0% and would cause Silhouette to hang 
if the GPU memory was exhausted.

https://borisfx.com/release-notes/particle-illusion-pro-2024-5-v17-5-3-release-notes/
https://borisfx.com/release-notes/sapphire-2024-5-3-release-notes/
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Interlaced Footage Lost Field 2
Field 2 of interlaced footage was replaced with a copy of field 1 when a node 
was added, for instance, blur.

Licensing
Help > License Did Not Open License Tool (Linux)
On Linux, Help > License does not open the License tool.

macOS 15 Rotate WiFi Address Licensing Issue
When enabled, macOS 15’s new Rotate WiFi Address opt-in feature randomly 
changes your device’s MAC address. If you activated a nodelocked license, it 
would eventually cease to work. The Mac licensing was upgraded to handle this 
new feature.

Matte Assist ML Crash With Animated DOD
With an animated DOD prior to a Matte Assist ML node, Silhouette crashed.

ML Nodes Did Not Work In macOS15
ML based nodes did not work correctly in macOS 15. For instance, Denoise ML 
and UpRes ML caused crashes and Optical Flow ML did not produce motion 
vectors.

Morph
Crash After Copy/Pasting And Then Viewing
A crash occurred after copying and pasting the Morph node and then viewing it.

Wireframe Did Not Playback
The Morph wireframe did not playback and was stuck on frame 1.

Motion Blur Node Artifacts
Slight filtering artifacts were visible on straight lines.

Paint - Stroke Not Visible While Viewing Another Node
When painting a stroke while viewing another node, the painted stroke was not 
visible.
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Pin Warp Keyframing With Parameters
When adjusting the Target X/Y sliders between existing keyframes, the Source 
X/Y positions were unexpectedly modified.

Regrain > Overlay Cell Pattern Resulted In A White Screen
Enabling Replace > Overlay Cell Pattern in Regrain produced a white screen.

Scripting - Custom Import Dialog Didn’t Support 
SFX_IMPORT_PATH

Silhouette’s custom import dialog didn’t correctly interpret a default import path, 
if set. It would always default to the system root.

Trees > Arrange Options Didn't Work
The Trees > Arrange options didn’t work.

UpRes ML + Cache + ROI Artifacts
There were image artifacts when using a Cache node after UpRes ML when 
ROI was enabled.

Viewer Did Not Display Source From Sources Window
The Viewer did not display the source from the Sources window.
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 SILHOUETTE 2024.5 - 9/12/24

Features
New Nodes

Mask ML
Mask ML is an easy to use point and click matte generator utilizing machine 
learning object segmentation. A single click selects a defined segment of the 
image while successive clicks add additional areas. Mattes are created on 
single frames and are useful as input to the Matte Assist ML node where the 
matte is propagated over time or to limit strokes in the Paint node.

Motion Blur
Motion Blur uses the Optical Flow ML node to generate realistic motion blur and 
requires a data input port connection from the Optical Flow ML node.

Roto > Markup Tool
The Roto > Markup tool creates trackable strokes with associated notes to 
identify shapes that require revision. Click-drag to draw a freehand stroke, 
Shift-drag to create a rectangle and Ctrl/Cmd-drag to draw an arrow. The 
strokes have note, range, color, and complete parameters and are displayed 
with a callout from the Viewer > Notes sidebar to the object. Markup objects can 
be repositioned, tracked when placed in a tracked layer, and checked off when 
completed. When selected in the Viewer > Notes sidebar, the Timebar 
automatically jumps to the Range start frame.

User Interface Enhancements
Node Highlighting
Tree render status is provided by highlighting each node as it processes using 
a blue outline.

Progress Bars
Progress bars are displayed for EZ Mask, Flow->ST, Matte Assist ML, and 
Power Matte above the status bar as well as within these nodes in the tree.
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Responsive UI
Implemented rendering in a thread so the UI remains responsive during 
playback and when dragging through render intensive nodes/trees.

Cache View > Purge Frame
Added a Purge Frame option in the Cache window which purges the current 
frame.

Sliders
Enable full size sliders with the User Interface > Show Sliders In Parameter 
Views preference.

Actions
Layer > Remap Reference Frame
The frame where tracking starts is considered the reference frame. In an 
example of tracking from the first to last frame, painting a clean plate on the last 
frame, and then applying the layer transform to the painted frame, the resulting 
layer transform would not produce the desired result. In this case, remapping 
the layer reference frame to the last frame solves the problem.

Notes
The Notes > Export and Import actions allow notes to be exported and 
imported.

Export
Exports notes from the current node to a file.

Import
Import notes from a file and applies it to objects in the current node. The objects 
must be the same objects as when exported.

Mocha Pro 2024.5
Mocha Pro has been updated to v2024.5.1. For a complete list of features, fixed 
bugs and changes, see: Release Notes

https://borisfx.com/release-notes/mochapro-2024.5-release-notes/
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Particle Illusion 2024.5
Particle Illusion has been updated from v2024 to v2024.5.2. For a complete list 
of features, fixed bugs and changes, see: Release Notes

Module Upgrades
EXR - Upgrade To v3.1
EXR was upgraded to v3.1.

OpenColorIO - Upgrade to v2.2
OpenColorIO was upgraded to v2.2.

Node > Options Enable Cache
Enable Cache determines whether a node is cached. Disabling the cache 
causes the node to compute every time it's asked to.

Optical Flow ML
Added a Model pop-up menu with Better and Faster options. Better is used 
when accuracy is important, for instance, Tracking. Faster is used where 
accuracy is less important, for instance, Motion Blur.

Scripting >  Command-Line -project <name>
It was a requirement that the project name be either the first or last command, 
but the new -project <name> flag allows the project name to be positioned 
anywhere in the command chain instead of only at the beginning or end.

https://borisfx.com/release-notes/particle-illusion-pro-2024-5-v17-5-0-release-notes/
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Changes
Auto Paint Default Frame Range

The Auto Paint frame range now defaults to Work instead of All Frames.

Default Interpolation / Interpolation Engine Preferences
The Default Interpolation and Interpolation Engine preferences don’t know 
about each other and it is possible to get them out of sync. Info text was added 
to these preferences to outline the appropriate settings for each option.

External Monitor - OCIO Color Transform Now Applied
The OCIO viewer color transform is now applied when using a Blackmagic I/O 
device.

Trees Preference Group
The User Interface > Trees preferences were moved into their own Trees 
group.
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Bug Fixes
Dot Node Placed After A Tracker

When clicking a Dot node placed after a Tracker, a "Bad dynamic_cast!" error 
appeared and Silhouette crashed.

Grunge Node Crash
The Grunge node caused a crash when adjusting the Gate Weave > Amount.

Matte Assist ML With DOD/ROI
When using Matte Assist ML with a DOD node or ROI, the matte would not be 
generated in some cases.

Mocha Pro > Shape Data Copy/Paste Crash
When Silhouette shapes were exported from Mocha Pro with the Copy to 
Clipboard option and then pasted data directly into the Silhouette Trees 
window, a crash occured. Normally, the workflow would be to paste the data 
into a Roto or Tracker node, but the Trees window paste should not have 
caused a crash.

Optical Flow ML
Vector Density
The Vector Density was too dense when zoomed out.

Vectors Were Misaligned When Using Proxies
Optical Flow vectors were misaligned when the Viewer was set to a proxy.

Particle Illusion - Corrupted Output (Mac)
Particle Illusion produced corrupted output.

Pin Warp X/Y Source Parameters Disabled Warping
Adjusting the Pin Warp > X/Y source parameters caused the pin to stop 
warping the image.
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Plug-in
User Interface Took Too Long To Load On The First Run (Mac)
On Mac, the first time opening the Silhouette plug-in interface after installation 
took a long time.

Premiere Pro
Misreporting The Resolution
Silhouette requires a full size image but Premiere Pro often misreported the 
correct resolution even though it was set to Full and then threw an error. 
Silhouette now always brings in a full size resolution image from Premiere 
regardless of how the playback resolution is set.

Loaded Entire Clip Instead Of Trimmed Footage
If a clip was trimmed in Premiere Pro, the entire clip was loaded into the 
Silhouette plug-in instead of the trimmed clip.

Resolve > Loaded Entire Clip Instead Of Trimmed Footage
In Resolve, the entire clip was brought into Silhouette instead of the trimmed 
version.

Roto
Flow Tracking With ST-Maps Did Not Work
Flow tracking with ST-Maps did not work.

Selection Issues With Extreme Layer Transforms
With stabilization enabled and an extreme layer rotation, shapes within the 
layer could not be selected.

Snapping X-Spline Point Caused A Crash
Pressing Alt-S to snap an X-Spline point crashed Silhouette.
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Scripting
Command-Line
Missing Node: Lens Correction
When attempting to command-line render a project with a Lens Correction 
node, the following error was produced: Missing Node: Lens Correction.

Multiple Output Nodes Issues
When there were multiple output nodes in the session, using -node “Output 1” 
-node “Output 2” -node “Output 3” in the command-line only rendered the 
Output 3 node.

Setting session.startFrame - UI Refresh
When setting session.startFrame from Python, the UI didn’t notice the change.

Transform > Edge Mode And Generated Alpha
When using Transform > Edge Modes like Reflect, the generated alpha was 
restricted to the original image area and not the entire frame.

User Interface
Additional Viewers Didn't Display Alpha
Additional viewers didn’t display alpha.

Duplicate Stability Nodes
There were duplicate Stability nodes.
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 SILHOUETTE 2024.0.1 - 7/15/24

Changes
Local Cache Disabled When Using Command Line

The local cache is now disabled when command-line rendering. 

Bug Fixes
Crash Loading A Nodes File

Silhouette crashed when loading certain node files.

Custom Importer UI Couldn’t Navigate To Network Drive
It was not possible to navigate to a network drive on Mac using the custom UI 
importer.

DeckLink HD Playback Slow In Silhouette
1920x1080 HD playback was slow when using a DeckLink output device.

Exporting Silhouette Shapes From A Mocha Tracked Layer 
Silhouette shapes exported from a Roto node created with the Mocha Pro > 
Create Roto Node action did not import.

Flame Hung When Opening Silhouette In Rocky 9 (Linux)
Flame hung when opening the Silhouette interface in Rocky 9. However, Flame 
should be launched from the Terminal in Rocky 9 to avoid other known issues.

GStreamer 
Anamorphic Render Not Tagged Properly
Rendering an anamorphic file using GStreamer did not get tagged as 
anamorphic.

Render Hang
Rendering to a GStreamer movie file hung Silhouette at ~90%. This was 
caused by a GStreamer bug where if another application which also uses 
GStreamer used it fist, other applications would hang.
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Mocha Tracker Crashed With Images Not Divisible By 4
The integrated Mocha tracker crashed when using images not divisible by 4.

Retime ML Didn't Pass An Image When Disabled
The Retime ML node didn’t pass the input image through when it was disabled.

Scripting > session.workRange Produced Incorrect Values
The session.workRange queried the frame range improperly and produced 
incorrect values like 0.0, -1.000002552296.

Transform Node
Blurry With Extreme Corner-Pins
At certain extreme Corner-Pin settings, a portion of the image was blurry.

Overlay Didn’t Match Image When Rotating
Rotating in the Transform node caused the bounding box to become 
disassociated from the edges of the image.

User Interface
Floating Viewer Crash
If a node viewed in a floating viewer was deleted, Silhouette crashed.

Image Generators - Custom DOD Controls Were Missing 
In the image generator nodes, the DOD controls were missing when Format 
was set to Custom.

Motion Blur Controller Parameters Couldn't Be Enabled
The Motion Blur Controller parameters were grayed out and couldn’t be 
enabled.

Stereo Viewer Controls Disappeared With Slap Comp
In a stereo project, the Stereo viewer controls disappeared when Slap Comp 
was selected.
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 SILHOUETTE 2024 - 6/6/24

Features
New Nodes

Matte Assist ML
Automatically generates a matte over time based on single or multiple 
keyframed roto shapes or input mattes using machine learning object 
segmentation and propagation.

Optical Flow ML
Generates machine learning powered optical flow data for use in one of the 
Roto based node’s Flow Tracker: Roto, Roto Blend, Tracker, Power Mask, 
Morph and Depth. Optical flow estimates per-pixel motion between frames and 
can be used to track shapes and objects.

Retime ML
A machine learning motion estimation and retiming model that produces 
smooth motion. Expands or contracts the timing of a selected range of frames.

EZ Mask
EZ Mask is an easy to use interactive image matting tool capable of isolating 
almost any object in an image--even when dealing with fine hair detail, smoke, 
or reflections. Mattes are created on single frames and are useful as input to 
the Matte Assist ML node where the matte is propagated over time or to limit 
strokes in the Paint node.

ST->Flow
The ST->Flow node converts ST-Maps to optical flow. This is useful when using 
a Nuke Smart Vector generated ST-Map, for instance, as input to the Flow 
tracker located in the Roto nodes.

Flow->ST
The Flow->ST node converts optical flow to ST-Maps. This is useful if you want 
to use the optical flow data in another program.
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Cache
Caches the result of all upstream nodes to disk, alleviates the need to 
reprocess that section of the Tree and loads as fast as a source file.

Trimap
Converts a matte into a trimap by adding unknown area to the edge of white 
matte areas. Trimaps are pre-segmented images consisting of three regions of 
foreground, background and unknown. When plugged into the Power Matte 
node, partial opacity values are then computed only for pixels inside the 
unknown region.

Mocha Pro 2024
Mocha Pro has been updated from v2023.5 to v2024. New features include 
camera solve with SynthEyes, enhanced tracking/roto tools and performance 
improvements.

For a complete list of features, fixed bugs and changes, see: Release Notes

Sapphire 2024.5
Sapphire has been updated from v2023.5 to v2024.5. New features include 
Dust, PixelMosh and DissolvePixelMosh, more lens flares as well as expanded 
support for macOS metal.

For a complete list of features, fixed bugs and changes, see: 2024 Release 
Notes and 2024.5 Release Notes

Particle Illusion 2024
Particle Illusion has been updated from v2023.5 to v2024. New features include 
new 2024 Emitter Library, generative AI sprite creation via Stability AI, particle 
lines can be true 3D objects, more native parameters, performance 
enhancements, and numerous user interface improvements.

For a complete list of features, fixed bugs and changes, see: Release Notes

https://borisfx.com/release-notes/sapphire-2024-release-notes/
https://borisfx.com/release-notes/sapphire-2024-release-notes/
https://borisfx.com/release-notes/continuum-2024-v17-0-0-for-adobe-ae-premiere-release-notes/
https://borisfx.com/release-notes/mochapro-2024-11.0.1-release-notes/
https://borisfx.com/release-notes/sapphire-2024-5-release-notes/
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Node Improvements
Denoiser
New v3 models process frame by frame and much quicker than the previous v2 
models which processed in 6 frame chunks.

DOD
The DOD > Format menu (... icon) has three new entries: Session Size, 
Session ROI, and Input DOD.

Paint
Brush Spacing
The range for the Spacing control was changed from 5-100 to 3-900.

Custom Brushes
Select from a set of custom brushes in the Brushes tab. Photoshop brush files 
with an ABR extension can also be imported.

Detail Separation
The Detail separation algorithm is new and improved. Paint strokes are 
smoother with larger brushes and auto painting color and detail strokes is now 
twice as fast. Paint nodes added in Silhouette 2023.5 and earlier will still use 
the previous algorithm, while newly added Paint nodes use the new method.
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Grain Brush > Gang
Added a red, green and blue Gang control for the Grain and Blemish brush’s 
Size, Amount and Softness parameters.

Power Matte > Trimap Input
Power Matte can now process with an optional trimap input. Trimaps are 
cumbersome to create manually, but a good workflow is to use the Matte Assist 
ML node to create an initial matte followed by a Trimap node connected to the 
Power Matte > Aux Trimap input.

Roto
Auto Keyframe (K)
The K shortcut key automatically calculates and sets a keyframe on the current 
frame if there is a source connected to the Data input, for instance, the Optical 
Flow ML node.

Flow Tracker
The Flow tracker uses optical flow to track a shape’s points. When either the 
Optical Flow ML, PowerMesh Warp or a ST->Flow node is connected to one of 
the Roto based node’s Data input ports, the Flow tracker becomes enabled and 
you can track a shape’s points. 

The Flow tracker can be used in conjunction with a Point, Planar or Mocha 
tracked layer. The layer tracks the general camera motion while the Flow 
tracker tracks the remaining motion of a deforming object.

Core Check
Displays the last hard pixel in the alpha channel when using soft shapes. When 
Core Check is enabled in the Viewer > RGBA context menu, a small dot in the 
alpha pot appears.

Create Layer From Shapes
Creates a tracked layer based on the shape keyframes as well as the layer 
transform, if present. When multiple shapes are selected, the control points 
from all of the shapes are considered and then generates a new layer. To use 
this feature, select a shape within the Tracker, right-click and select Create 
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Layer from Shapes. This is useful in the Flow Tracker, for instance, where the 
motion is applied to controls points instead of a layer. The newly created layer 
can then be used to transform other nodes.

Memory Usage Reduced
All roto control points were 3D even though the z coordinate was never used. 
By replacing the Point3D used everywhere in Roto with a Point2D, it cuts 
memory for shape data by 33% and avoids redundant calculations in the matrix 
transforms.

MultiFrame Enhancements 
New editing modes along with fade in and out shortcut keys allow you to 
achieve something that was once considered impossible: easily editing shapes 
or objects with keyframes on every or many frames.

Mode
The Mode pop-up menu includes Custom, Center and Auto options.

• Custom

Simultaneously adjusts shape keyframes over a specified range. The Start and 
End as well as the Fade In and Fade Out values appear in the Timebar when 
MultiFrame is selected. Alt-clicking in the Timeline > MultiFrame bar sets 
either the Fade In or Fade Out points, depending on which side of the current 
frame you click on, with the fade range going to the current frame.

Note: Custom is the same mode used in 2023.5 and below.

• Center

The adjustment is centered around the current frame for a duration specified in 
the Radius field and the adjustment eases in an out from the center.

• Auto 

Some nodes like the Point and Flow tracker produce keyframes on every frame 
in a combination of hard and soft keyframes. Hard keyframes are manually set 
and help guide the tracker’s generated soft keyframes. When making an edit, 
Auto mode smoothly interpolates the soft keyframes located between hard 
keyframes.
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Options
The Options menu provides a few MultiFrame range options.

• Reset to Work Area

Resets the Start, Fade In, Fade Out and End fields to the work range.

• Reset Fade Range

Resets the Fade In and Fade Out fields.

• Center On Current Time

Centers the Start, Fade In, Fade Out and End fields on the current time.

GPU Processing Enhancements
Performance
Images flow through the system and now remain on the GPU unless they need 
to be in memory for some reason. This results in much faster processing when 
multiple GPU nodes are used.

Preferences
% Total Physical GPU Memory
At a value of 0, GPU images are not cached. This means the GPU images will 
flow through from the first GPU image to the last without going through RAM, 
but it means every GPU node in the chain will render in sequence any time 
something changes. Increasing the value allows GPU images to be stored in 
the cache like RAM images, making editing faster.

Cache GPU Images
Controls whether GPU results go in the cache.

Pipeline GPU Images
Controls whether GPU results are passed on to the next node or downloaded 
to RAM.
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Use GPU Node Option
Nodes now have a new GPU group in their Options tab with a Use GPU 
checkbox. Enabled by default, it can be turned off on a node-by-node basis to 
force the node to render on the GPU.

Cache Improvements
Source Caching To Disk
Media from a slow network drive is automatically copied to a fast local drive 
once you specify the source and storage locations in the Cache > Local Cache 
preferences. Then, when you load a sequence from the slow network drive, the 
source node will see that it’s in the source path and copy it to the fast storage 
path. The next time the media is requested from the network drive, it will read 
it from the local cache instead.

Cache Utilization Is Smarter And More Efficient
Previously, Silhouette aggressively cached everything and this could be very 
wasteful depending on the context. Now, a much higher number of frames can 
be cached. The new cache behavior is:

• When playing or scrubbing, only the viewed node is cached in RAM.

• When parked or editing, the up-stream node as well as the viewed node is cached 
and it'll prefer caching on the GPU if it can.

Note: Sources are still always cached in RAM.

Cache Window
When enabled (Window > Cache), the Cache window displays useful 
information about what is cached and both the RAM and GPU caches can be 
purged.

Preferences
Cache > Mode
Sets the caching mode.
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Adaptive
When playing or scrubbing, it will only cache the currently active node. When 
parked or editing, it'll cache the immediate upstream node and the active node. 
In all cases, Silhouette will cache nodes that have multiple downstream 
branches.

Aggressive
Every node that can will cache.This is the behavior in 2023.5 and below.

User Interface > Trees > Show Cache State
When enabled, colored dot indicators are displayed on the output of nodes that 
cache. Blue dots are cached in RAM while green dots are cached on the GPU.

Improved Player Performance
The Player’s performance has been improved.

Scripting
External Package Path Preference
To aid in installing external Python packages (such as numpy, torch, scipy, cv, 
PIL, etc.), the External Package Path preference was added. It defaults to 
$(SFX_PYTHON_PACKAGES) which can also be set with an environment 
variable. When using the tools.installer script, it will first check for this 
preference and attempts to install packages there instead of in the built-in 
Python library which only works if there is write access.

project.is_modified Flag
To determine if the project has changed, a project.is_modified flag was added.

Script Editor > Find
Press Ctrl-F while the Script Editor has focus to pop up a Find field. Press Esc 
to exit find mode. Typing will search and set the selection to the next thing it 
finds that matches. Press Enter to go to the next instance.
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User Interface
Node > Options > Marker
In the Node > Options tab, you can now add, delete or jump to markers. 
Previously, adding or deleting markers could only be done in the Timeline. 
Markers are used to identify frames for use in the Matte Assist ML node as well 
as to write notes.

Power Mesh Warp Node Gets Data Output
A Data output was added to the Power Mesh Warp node as a way to drive the 
Flow tracker in the Roto nodes.

Render Time Of Last Image
To the left of the Color Sample field, the last frame’s render time is displayed in 
milliseconds.

Note: Once the tree has been cached, the field will display a value of 0.

RGBA Context Menu
Added a context menu to the Viewer > RGBA button with Invert Alpha and Core 
Check options.

Roto Nodes Get Data Input
Nodes that contain roto tools: Roto, Roto Blend, Tracker, Power Matte, Morph 
and Depth all get a Data input port. Either the Optical Flow ML, PowerMesh 
Warp or ST->Flow node can be plugged into this Data input.

Timebar > Current Frame Rate
A Current Frame Rate field was added to the Timebar to give an accurate 
reading of the exact frame rate during playback.

Changes
GPU Renders In The Session Depth

GPU effects were always rendered in half float, even in 8 bit or 32 bit float 
sessions. The rendering precision is now tied to the session depth.
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Bug Fixes
Colorize Gradient > Grad > Corner-Pin Issues

Some newer presets were added that incorrectly set the Grad > Corner-Pin. 
Now, the Grad > Corner-Pin controls are explicitly set to the corners of the 
image for all presets.

Crop
On-Screen Controls Were Missing
The on-screen controls were missing.

Random Point Control
The Crop node had a random point control at the top left corner.

Degrain in Nuke Froze For First 5 Frames
The Degrain node caused the image in Nuke to freeze for the first 5 frames.

DOD On Screen Controls Jumped
The DOD node on-screen controls jumped to the session size when a slider 
was adjusted.

Mocha Was Not Licensed In Host When Using The 
Silhouette Plug-in License

Mocha was not licensed in the host application when using the Silhouette plug-
in license.

ML Node Didn’t Update When Upstream Node Changed
Making a change upstream of a ML node did not update the Viewer until the 
Timebar was advanced 6 frames.

Output Multi-Part Additional Input Connections Not Saved
If you added additional Output Multi-Part inputs, saved the project and then 
reopened it, the additional output connections would be connected to the same 
port or disconnected upon reload.
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Paint
Crash Adding Paint Only to Composite FG With No BG Input
Connecting the Paint Only output into a Composite > Foreground input caused 
a crash when there was no background input.

Stroke Beyond Image Boundary Disappeared
When painting outside the image boundary with a larger ROI, the painted 
stroke was missing when returning to that frame.

Tiling Artifacts In Color/Detail Modes At Large Resolutions
Tiling artifacts occurred when painting at large resolutions in the Color and 
Detail modes.

Roto
Alpha Corruption With Incoming Alpha & Motion Blur
The Roto node displayed corruption in the Viewer when an input clip had an 
existing alpha channel and the shapes had motion blur enabled.

Nuke 9+ Exporter Exported Incorrect Motion Sample Value
The mapping of the Silhouette > Samples to Nuke > Motion Blur was not correct 
in the Nuke 9+ shape exporter. Nuke used a fractional value for its motion blur 
while the Nuke 9+ shapes exporter was using whole numbers. This resulted in 
Silhouette shapes imported into Nuke being really slow.

Obey Alpha Did Not Work Without Source Input
Roto > Obey Alpha did not work unless there was a source input connected.

Timeline Markers Not Created If A Note Was Not Entered
Timeline Markers were not created if a note was not entered.



Silhouette 2024 What’s New    

• 
• 
• 
•
•
•

Silhouette 2024 - 6/6/24  35 
• 
• 
• 
•
•
•

Known Issues / Limitations
GStreamer

ProRes
All ProRes movies are imported as 16-bpc. This is a limitation of the GStreamer 
ProRes decoder.

Rendering Interlaced Footage
Rendering interlaced footage is not supported at this time.

OpenColorIO - Particle Illusion and Flare Editor
OpenColorIO is not implemented in Particle Illusion or the Lens Flare > Flare 
Editor which results in the image in those interfaces not exactly matching the 
Silhouette viewer.

PowerMesh Warp
The PowerMesh Warp node renders a slightly different result than Mocha Pro.

Silhouette Plug-in
Flame
Upstream Node Changes Don’t Update Until Silhouette Is Opened
Upstream node changes in Flame don’t update when viewing the Silhouette 
plug-in unless Purge Cache is selected, the Render menu is toggled or 
Silhouette is opened.

Sequence Numbering
Flame is not obeying the OFX parameter that determines the start frame, so a 
Flame sequence starting at 1 instead starts at 0 in Silhouette.

Multiple Instances of Silhouette Plug-in
You can’t connect two Silhouette plug-ins in a row. There can be multiple 
Silhouette plug-ins, just not chained together.



   Silhouette 2024 What’s New

36 Silhouette 2024 - 6/6/24

• 
• 
• 
•
•
•

• 
• 
• 
•
•
•

Premiere Pro > Alpha Channels With Soft Edges
By default, Premiere Pro is linearizing the alpha channels exported from the 
Silhouette plug-in even though they are already linear. This causes the alpha 
to appear smaller when using soft edges. To avoid this issue, disable 
Composite in Linear Color in the Premiere sequence settings.

Resolve > Multiple Inputs
Resolve does not allow more than one input for plug-ins that use custom user 
interfaces. However, additional sources can be added directly within Silhouette.
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